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Motivation

A new electronics system was at the core of the overhaul of Ranger. The new electronics design was 

conceptualized at a high-level as a “nervous system.” The idea was to create one “main brain” board 

that communicates with satellite boards that control and interact with different parts of the robot. The 

idea for the electronics redesign was to create a certain number modules each designed to perform a 

specific task. The different modules would be combined together as necessary with to form the satellite 

boards. The “main-brain” board as well as the “user-interface” board were designed separately because 

of the very specific nature of their task. 

One of the main advantages of such a system was design efficiency. Instead of having to create each 

board from scratch, the boards could be created by combing different modules. For example, every 

board needs a power supply module and most need a microcontroller module. There are also some 

specific modules such as motor control that are only used on a specific board. This system also allows 

for quick creation of new boards if necessary. If the need arises for a new board the idea is that only a 

module needs to be designed and that module can be combined with others that have already been 

designed to form the new board. The purpose of this documentation is to help students working on 

design and layout of new modules and boards. This documentation contains information about the 

software, “how-tos,” and particular specifications for all boards built in this lab.



Creating a Schematic

1. Obtain Necessary Software: EAGLE is the software used in the lab for both schematic drawing 

and layout. EAGLE Light is available as a free download from 

http://www.cadsoftusa.com/download.html. While EAGLE light is a good starting point, most 

designs will require features only available in the full version. You can obtain the license key to 

upgrade your software from the lab manager.

2. Begin a New Project: Open EAGLE and select New --> Project. Begin by first drawing the 

schematic. Choose New → Schematic

3. Adding Components to the Schematic: In this step there are two cases, either the component 

exists in the EAGLE library or you must create a library entry for that component. For the latter, 

refer to the next section on creating a library part, otherwise click on the “Add” icon in the left-

hand side toolbar. The library should open. Browse or search the library to find your desired 

component. Highlight the component. If there are multiple packages for the device consult the 

part information and choose the appropriate package. It will be very helpful during layout if you 

have the right package selected. Click OK to exit the library screen and then place the 

component on the schematic by clicking anywhere on the sheet. At this point you can add as 

many instances of that component you need. You can leave “Add” mode by hitting ESC. 

4. Modify the Components: Be sure to label each component with the correct name and value. 

5. Wire the Components: Connect the components using nets. It is helpful to label these nets 

because it will help you fix any wiring errors.

6. Run ERC: Once you have finished the schematic, run ERC to try to catch any errors you have 

made in the design of your schematic. Do not move on to the layout phase if your schematic 

does not pass ERC.

Picture 1: New Schematic Sheet in EAGLE



7. A Few More Things: EAGLE schematic allows you to use multiple sheets. This is very helpful 

for a complicated module with lots of parts. The nets do not have to be physically attached as 

long as they are labeled the identically.

Creating an EAGLE Library Part

In some cases the part you need for your circuit cannot be found in the EAGLE library. In these cases, 

it is necessary to create a library entry in EAGLE for the part. The following are steps compiled by 

Jason Cortell to successfully add a part in EAGLE:

A. Use exactly one component per library file. This is not standard EAGLE practice, but it is 

necessary to maintain a version control of the boards. To get started, from the main EAGLE menu 

choose File → New → Library. From this library you will create symbols and packages and link them 

together to form a device.

B. Library Component Naming Convention: It is important to adhere to this convention because 

it makes the part searchable later and very clear what part it is when you are assembling the board.

1. Use all capital letters. Separate sections of the file name with underscores, not spaces 

or hyphens.

2.  The first letters (or two) is the component type: C for capacitor, R for resistor, L for 

inductor, J for connector or jack, D for diode, T for transformer, Q for transistors, and U 
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for ICs

3.  The next two sections of the name should give some clue to the function, if not 

obvious, and the manufacturer name, if not generic. E.g., J_USB_HIROSE

4.  The next section of the name should give the exact manufacturer's part number of the 

component, if the part is not generic. E.g. SN74LVC1G07DRLR

5. The final section of the name should give the standard designation for the package 

type, if available, or the full number assigned to it by the manufacturer, if available. 

C. To copy a preexisting library device or package, open the EAGLE control panel and find the 

desired device in the list view. If you don't see the folder you want click on the Options menu, then 

Directories..., and add the path to the library path search string. Open or create the destination library 

from the File menu in the Control Panel. You should see and empty window. Drag the desired device 

from the list view to the open destination library window. Save the destination library.

D.  To copy a library symbol (or package), open the source library and the desired symbol or 

package, then use the dashed-square group selection tool to select the entire package or symbol (make 

sure all the layers are displayed). Then use the cut (scissors) tool to copy it to EAGLE's clipboard, open 

a new symbol or package window in the destination library, and use the paste tool to insert it. Note that 

even if you open multiple copies of EAGLE on the same computer they won't talk to one cannot and 

you cannot copy from one and paste to the other. 

E. Making a new Library Symbol

1. From the library main menu, choose Symbol and enter the name of the new symbol. 

Following the naming convention specified above.

2. Put the origin of the symbol in the exact center of the part, unless you have a very 

good reason not to. This makes placing the symbols and moving much easier later.

3. Use the Symbols layer to draw your schematic representation of your component. A 

simple rectangle is an easy way to get started with an IC. 

4. Add pins. I usually put the input pins on the left and the output pins on the right. 

Power supply pins can be at the top and bottom. Choose appropriate directions for the 

pin functions. E.g. input, output, power, NC, passive. Avoid using supply pins because 

they have the power to rename your signals and nets, possibly causing trouble (use 

power pins for Vcc and GND, for example).

5. Add pin function names where needed. If the functions are obvious from the symbols 

shape you don't need them. (Eg. Diode cathode and anode)



6. Turn on or off pin names and numbers. (The numbers will come from the package and 

the connections linking symbol to package when you put them together to make a 

device).

7. Add  >NAME and >Value on layers Names and Values, using 0.07 proportional font 

at 8% ratio.

8. For the symbol, use only a 0.1 inch grid; otherwise you will not be able to connect 

wires to your part. No metric here (for the package it is fine).

F. Making a new library package:

1. From the library, choose package and edit. Name the package appropriately.

2. Put the origin in the exact center of the part, unless you have a very good reason not 

to. Machine part placement will not work otherwise. 

3. Use 8 mil lines for silk screen layers (tNames, bNames, tPlace, bPlace). For surface 

mount devices, put the lanes on the top copper. 

4. Use layer tNames for silkscreen text information. Use later tPlace to show placement 

location and orientation of parts. These should not overlap the pads, solder mask, etc. 

5. Use layer tDoc for visual representation of the part for layout and documentation 

purposes. This should show the actual profile of the part and its leads, etc. Its okay for 

this to overlap the pads because it will not be on the silkscreen. This also helps to 

maintain clearance between parts during board layout. 

6. Solder mask layer tStop should be 3 mils larger than the copper in every direction. 

This is normally a setting in the DRC, but if end up making oddly shaped pads with 

polygons then you'll need to know this. 

7. Add >NAME and >VALUE on layers tNames and tValues, respectively using 0.04 

vector font at 20% ratio. 

8. Add a tKeepout boundary if the part is larger than the land pattern in any direction or 

if extra room is needed for soldering. Add tRestrict layer lines to keep our 

polygon/power layers from under a part. 

G. Making an New Library Device

1. From the main library window, select device and name accordingly.

  2. Add symbol from the list of available symbols in the library. 

3. Add package or packages from the list of available packages. In some cases the exact 

same part is available in different packages and you may want to create a package for 



each one. Instead of creating a new part for every different package, multiple packages 

can be attacked to one symbol.

Creating a Layout

1. Starting a Layout: To switch from board to layout, go to File → Switch to Board and create a 

new board. Please carefully read and the layout specifications in the table below.  In this lab, we only 

design 4 -layer boards because it keeps manufacturing costs down. The table at the end of this section, 

compiled by Jason Cortell,  provides specific criteria for board sizing, appropriate layer use, and 

running the Design Rules Check. 

2. Layout Tips and Tricks:

A. Designating Board Area: Carefully following the specifications in the table, set your 

board area. All components must be placed within this area.

B. Planning Out Board: Before laying down any traces, arrange components within the 

area. There will be yellow lines called “airwires”  between components indicating 

necessary connections. Try to arrange components such that the traces do not have to be 

very complex between components. 

C. Using Supply planes: Certain layers are primarily for use as either ground or power 

supply planes. Occasionally it will be necessary to create power polygons on other 

layers of the board. There is a polygon drawing tool. 

Picture 3: Example of a Library Part Entry



D. Viewing layers: The display button allows you to choose which layers you want to 

view. Also, when you are putting down traces, the top left tool bar indicates which layer 

you are drawing traces on. There is a drop-down menu to change layers. 

E. Using Vias: Vias allow you to connect traces on different layers as well as connect to 

the ground and power planes. General rule in the lab is that the fewer vias on the board 

the better because vias increase the cost of the board. 

F. Removing traces: Use the “rip-up” tool to remove unwanted traces. 

G. Running DRC check: You must run DRC with the setting specified in the above table. 

This is crucial to ensure the board will be functioning. See section on final error checks 

for all checks that must be run before the board is completed.

Criteria for All Electronics Boards Designed for the Lab:

Parameter Value Comments

Height (Y direction) 30 mm (1.182 inches) Modules with Connectors

Height (Y direction) 18 mm (0.787 inches) Modules without Connectors

Length (X direction) Multiple of 1 mm (0.0394 in) As short as is feasible

Mounting Holes

Number of Holes 2

Vertical Position Centered

Horizontal Positions >=3mm (0.118 in) from ends, It may be useful on some boards to 
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in 1 mm (0.0394) increments have a vertically oriented connector on 

the end of the board with the mounting 

screw located closer to the board 

center.

Hole Diameter 3 mm (0.118 in) For 3mm or #4 screw

Board Layers – 4-Layer Boards All modules need to be 4-layer boards

First (top) copper layer EAGLE Layer 1 For internal module wiring and power 

polygons (planes) when possible. Use 

mostly vertical traces. Try to minimize 

use of horizontal traces

Second (internal) copper layer EAGLE Layer 2 Primarily for module to module 

interface wiring. Leave plenty of space 

for future module wiring. All traces 

should be horizontal. NO Vertical 

traces allowed

Third (internal) copper layer EAGLE Layer 15 Primarily for ground planes. Should not 

be used for other connections, but may 

be separated into analog and digital 

ground planes. A LAST RESORT for 

unexpected connections. Try to avoid 

damaging the ground plane continuity.

Fourth (bottom) copper layer Primarily for power supply planes, with 

some traces and components as needed. 

Traces should be mostly vertical – Try 

to avoid horizontal traces. 

Additional EAGLE Layers

Pads EAGLE layer 17

Vias EAGLE layer 18

Unrouted EAGLE layer 19 Should be empty when you are done 

with your layout!

Dimension EAGLE layer 20 For module board outline only. Use 

width of 0 to avoid ambiguity. Include 

in silkscreen gerber files, though they 

probably won't appear on the board.

tPlace EAGLE layer 21 Default location for top-side 

component placement lines. EAGLE 

library parts have 5 mil line widths. 

These are too narrow for board houses 



so they all need to be increased to 8 

mil. 

bPlace EAGLE layer 22 Default location for bottom-side 

component placement graphics. See 

tPlace. 

tOrigins EAGLE layer 23 Component origins, top layer. Select 

components with these. Turn off the 

layer if you don't want to select them 

accidentally. 

bOrigins EAGLE layer 24 Component origins, bottom layer. 

Select components with these. Turn off 

the layer if you don't want to select 

them accidentally. 

tNames EAGLE layer 25 Component names, top layer. These 

will appear in the silkscreen graphics. 

All text must have an 8 mil line width. 

To achieve this, use 0.04 in height, 

vector font, and 20% width/height ratio

bNames EAGLE layer 26 Component names, bottom layer. These 

will appear in the silkscreen graphics. 

All text must have an 8 mil line width. 

To achieve this, use 0.04 in height, 

vector font, and 20% width/heigh ratio.

tValues EAGLE layer 27 Component values, top layer. Do not 

include in silkscreen gerber file.

bValues EAGLE layer 28 Component values, bottom layer, Do 

not include in silkscreen gerber file. 

tStop EAGLE layer 29 For generation of top soler mask gerber 

files

bStop EAGLE layer 30 For generation of bottom solder mask 

gerber files.

tCream EAGLE layer 31 For generation of top solder paste 

stencil file

bCream EAGLE layer 32 For generation of bottom solder paste 

stencil file.

tGlue EAGLE layer 35 For generation of top glue stencil file 

(holds components down temporarily 

for soldering). We probably won't use 

this. 



bGlue EAGLE layer 36 For generation of bottom glue stencil 

file (holds components down 

temporarily for soldering). We 

probably will not use this

tKeepout EAGLE layer 39 Shows component space required for 

ease of installation, top side

bKeepout EAGLE layer 40 Show component space required for 

ease of installation, bottom side. 

Drills EAGLE layer 44 Shows drill locations for vias and pads 

(plated holes). Don't include in gerber 

silkscreen file, but do include in gerber/

Excellon drill file.

Holes EAGLE layer 45 Shows drill locations for unplated 

holes. Don't include in gerber 

silkscreen file, but do include in gerber/

Excellon drill file. 

tDocu EAGLE layer 51 Shows component icons on top layer, 

to make it easier to understand the 

layout. Don't include in silkscreen.

bDocu EAGLE layer 52 Shows component icons on bottom 

layer to make it easier to understand 

the layout. Don't include in silkscreen

Layout Design Rules for 4-Layer 

Boards

These rules are intended to help make 

the various modules compatible and to 

keep fabrication costs down. 

Minimum trace width 7 mils (0.178 mm) This and the space width below are a 

little larger than the minimum for 1-oz 

thickness copper, but we would like to 

be able to use the same module designs 

with motor controllers and other power 

circuits on 2-oz copper. 

Minimum space between copper 

objects

7 mils (0.178mm) See above. 

Minimum hole size 15 mils (0.381mm) Vias, pads, holes, etc.

Minimum annular ring - vias 5 mils (0.127 mm) Radial distance. EAGLE calls this 

“restring.” The copper shape around a 

via should be at least 10 mils larger in 

diameter than the hole itself. 



Minimum annular ring - pads 7 mils (0.178 mm) Radial distance. EAGLE calls this 

“restring.” The copper pad around a 

component pin hole should be at least 

14 mils larger in diameter than the hole 

itself. 

Minimum copper to PCB edge distance 20 mils (0.508 mm) Distance from board edge to closest 

traces. 

Minimum inner layer clearance 10 mils (0.254 mm) Distance from board edge to closest 

traces. 

Solder mask clearance 3 mils (0.076 mm) Distance from edge of pad to start of 

solder mask.

Silkscreen line width 8 mils (0.203 mm) Minimum line width for text, part 

placement graphics, etc.

Font EAGLE vector font This font allows user-selected 

thickness/height ratio; the proportional 

one does not. 

Character thickness/height ratio 20% EAGLE “ratio” parameter Gives 8-mil line thickness with 40-mil 

character height

Minimum text height 40 mils (1.016 mm)

EAGLE DRC (Design Rules Check) 

Setup for 4-Layer Boards

Do a DRC check by clicking on an icon 

showing a magnifying glass full of 

traces and pads. 

Note that many of the DRC settings go 

beyond error checks and actually 

change your board layout. 

Layers (1+2*15+16) Setup

Clearance 7mil (all)

Distance 20mil Copper/dimension

8mil Drill/hole

Sizes 7mil Minimum width

15mil Minimum drill

Restring 7mil Minimum pads

5 mil Minimum via

Masks 3mil Solder Mask Swell, Min

10% % of mind. SMD Dimension

4mil Solder Mask Swell, Max

0mil Cream

Misc. Angle Check On



Copying a Module to a Board

The boards are meant to be combinations of difference modules in order to complete a certain function. 

This section provides step-by-step instructions for successfully copying a module to the board 

compiled by Jason Cortell:

1. Check that all your component and net names are unique between the two boards. Each 

module/unit should have a unique prefix number. For example, the LPC2194-CAn unit has 

component numbers starting at 100 and net names with a 1_prefix. Don't forget to check the 

ground and power symbols on the schematic, and even the page frames. They have names 

too. 

2. Make backup copies of your files. This process can completely ruin your layout and 

schematic if something goes wrong. 

3. Open the source board file. 

4. Turn on all layers, then use the selection tool to select the whole board. 

5. Use the cut (scissors) tool to copy the board layout to the paste buffer. 

6. From the same instance of EAGLE, open the destination board file. DO NOT open the 

schematic file. Turn on all layers. 

7. Use the paste (paintbrush) tool to copy in the layout. 

8. Save and close the board file. 

9. Open the source schematic. Starting with the first schematic sheet, use the selection tool and 

select the entire schematic, including the page frame. 

10. Use the cut (scissors) tool to copy the schematic to the paste buffer. 

11. Open the destination schematic. Ignore the warning that the schematic and board are not 

consistent. DO NOT do anything else – e.g. ERC, RATSNEST

12. Create a new schematic sheet and paste in the module schematic. Save the file

13. Repeat the previous four steps for each additional schematic sheet in the source file

14. Now run the ERC check. This hopefully will show you that the operation was successful. It 

also reestablishes the forward-back annotation so that you can start editing the combined 

files. 



Finishing Your Module or Board

1. Run the DRC Check: Are all layers on? Stop mask errors are generally due to silkscreen 

printing in areas with no stop mask. Make sure there aren't any when you turn off the silkscreen layers 

(tPlace, tNames, bPlace, bNames, Dimension). Drill errors tend to indicate that there are two vias in the 

same place. 

2. Run the ERC Check: Watch out for connections that look real but aren't. You may need add 

junctions here and there. Since we are building modules intended for connection to other modules, you 

can approve the various errors related to pins with only one junction. 

3. Check your library parts: Even devices that were in already in an EAGLE library can have 

errors. Some possible problems:

a. Do the pins physically line up with the copper areas (lands). The lands should not be 

too small in any area.

b. Is the pin number of the pads/SMDs the same as the pin numbering shown on the data 

sheet. Use the info tool to see the numbering.

c. Check the connections against the data sheet one more time.

4. Update Parts: Update your library parts from your module library

5. Name all Parts: Make sure that all components on the schematic and layout are named.

6. Rerun all Checks: This includes ratsnets, which will show any remaining airwire, DRC and 

ERC. This is in case anything went wrong in the previous checks. 

7. Double Check: Export gerber files and upload them to www.freedfm.com for an additional 

check. If any repairs are needed, you'll have to run the ratsnest, ERC, DRC, again.

http://www.freedfm.com/

